dissabte, 21 d’abril de 2012

Funció SI en excel amb anidacions

L'objectiu és determinar a quin quadrant pertany un angle. Caldrà doncs aplicar un SI (o if) amb tres nivells. El quart no és necessari ja que serà el resultant de no aplicar les anteriors condicions.
En el nostre cas els angles van de 0 a 180 graus pels quadrants 1 i 2 i de 0 a -180 pels quadrants quatre i tres. En l'exemple queda més clar.






















La funció aplicada al valor en A2 és

=SI((A2>=0)*Y(A2<=90);1;SI((A2>90)*Y(A2<=180);2;SI((A2<0)*Y(A2>=-90);4;3)))

El resultat:





Però l'important d'aquesta entrada és explicar la formula EXCEL d'anidacions de if.



De fet és tan simple com mantenir la coneguda estructura =SI(CONDICIO;ResultatA;ResultatB)



El truc està en ampliar poc a poc els resultats. Amb una mica de paciència aquest gràfic penso que ho deixa bastant clar. Cal fixarse que sols afegim el símbol = la primera vegada.



Per afegir el Y que uneix dos condicions fem servir * abans de la Y.




En qualsevol cas, això és matar mosques a canonades. La gràcia del si (o del if) es que evalua fins que troba un resultat. Es a dir, si en el primer "pis" troba una solució, ja no continua. per tant, la forma correcta seria:


=SI(A2>90;2;SI(A2>0;1;SI(A2<-90;3;SI(A2<0;4;0))))


En aquest exemple millorat, si el angle és 0 ho marquem com a quadrant 0.


Cap comentari:

Publica un comentari a l'entrada